WordPress 2.5.1, requiere actualización inmediata, sobre todo con usuarios registrados

La noticia ya es de ayer pero puede que a alguno os haya pillado en la desconexión del fin de semana. Han liberado la versión 2.5.1 de WordPress con importantes mejoras para el CMS (gestor de contenidos).

Esta nueva entrega de WordPress solventa un importante y grave bug que según informan desde WP, no es público pero lo será pronto y caso (como sucede con este blog) de que se tenga habilitado el registro de usuarios la actualización es urgente.

Dan la posibilidad también de descargar únicamente los ficheros más afectados por las mejoras (wp-includes/pluggable.php, wp-admin/includes/media.php, wp-admin/media.php) pero os recomiendo actualizarlo al completo.

Además de esa vulnerabilidad que os comentaba, se han mejorado otros aspectos del software como pueden ser la subida de ficheros, nueva versión de TinyMCE, gestión de categorías, visionado en IE, el panel de admin y la escritura y edición de post. Al igual que en otras ocasiones, el amigo Alex Concha (de Buayacorp) sale en los créditos -;).

Por cierto, muy recomendable el uso de la “secret Key” a incluir en vuestro wp-config.

Más información y descarga

[tags]Wordpress, Webmaster, blog, bítacora, CMS, actualizacion, 2.5.1, seguridad, bug[/tags]

dabo

Hola, soy Dabo, el fundador de Daboweb y Caborian y desde este espacio solo pretendo poder comunicarme con vosotros lejos de las temáticas y contenidos que tratamos allí. Bienvenidos a mi rincón...

dabo escribió 1246 entradas

Navegación de la entrada


Comentarios

  • dabo

    Uff y luego dicen que exagero…Deface a Alt1040, WP versión 2.5…se está poniendo jodido el tema de los updates de WordPress pero cuando pongo “urge actualizar” es porque además de que lo digan desde WordPress, en otros sitios paralelamente comienzan a publicar exploits, etc, etc y luego pasa lo que pasa, en fin me da que no va a ser el último porque nadie está libre de que le cojan con el pie cambiado y más en fin de semana ya que hay vida después del blog…

    http://alt1040.com/2008/04/si-alt1040-fue-hackeado/

  • destroyer

    Hay que revisar unos archivos por un problema con el cambio de contraseñas, tienes un mail ;)

  • dabo

    Gracias Dest, lo lei ya, parece que hay problemas cambiando el password de admin vía perfil del wp, aquí hablan del tema y de la solución; (Inglés, vía noticiastech)

    http://cubegames.net/blog/2008/04/27/reset-password-bug-patch-and-fixed-files/

  • rafa espada

    Contentos me tienen estos… resulta que ya no se pueden tener categorías con el mismo nombre aunque dependen de cat
    egorias “padres” diferentes… vamos… que ya no se pueden tener :

    Enero>>vídeos
    Febrero>>vídeos

    Y con respuestas de los desarrolladores tan tajantes como estas… “From forum mod -> Duplicate Category (and Tag) names are no longer allowed.” da un poco por el saco.

    p.d. últimamente el software libre me me mira con el ojo malo… joder.

    Es desde la versión 2.5.

    En esta 2.5.1 han corregido el que el gestor de medios no funcionase en Explorer (me lo han dicho unos que usan explorer, que yo ni idea de ese).

  • rafa espada

    Rectifico… si se pueden crear categorías hijas con mismos nombres… pero deben ser diferentes los títulos. Un poco coñazo si tienes que adaptar muchas categorías… pero se puede.

    Creo que hoy podré dormir…

  • dabo

    jaja duerme Rafa duerme y a mi me da guerra la gestión de usuarios, es decir, echo de menos la posibilidad de ordenarlos por fecha de registro y no por orden alfabético, he estado mirando algunos plugins y no me acaban de convencer….

Comentarios cerrados.